Skip Menu |
Report information
Id: 132247
Status: open
Priority: 0/
Queue: perl5

Owner: Nobody
Requestors: ben-goldberg [at] hotmail.com
Cc:
AdminCc:

Operating System: mswin32
PatchStatus: (no value)
Severity: low
Type: library
Perl Version: 5.20.2
Fixed In: (no value)



Subject: XSLoader and DynaLoader documentation bugs
From: Benjamin Goldberg <ben-goldberg [...] hotmail.com>
To: "perlbug [...] perl.org" <perlbug [...] perl.org>
Date: Sun, 8 Oct 2017 15:46:03 +0000
Download (untitled) / with headers
text/plain 3.7k
This is a bug report for perl from ben-goldberg@hotmail.com, generated with the help of perlbug 1.40 running under perl 5.20.2. ----------------------------------------------------------------- [Please describe your issue here] The documentation of XSLoader and DynaLoader do not make use of __PACKAGE__, and use outdated indirect method call syntax. For example, this line from the doc: XSLoader::load('YourPackage', $VERSION); Should read: XSLoader::load(__PACKAGE__, $VERSION); Or alternatively: __PACKAGE__->XSLoader::load($VERSION); And this line: bootstrap YourPackage $VERSION; Should read: __PACKAGE__->bootstrap($VERSION); [Please do not change anything below this line] ----------------------------------------------------------------- --- Flags: category=library severity=low module=XSLoader --- Site configuration information for perl 5.20.2: Configured by strawberry-perl at Sat Feb 21 18:05:55 2015. Summary of my perl5 (revision 5 version 20 subversion 2) configuration: Platform: osname=MSWin32, osvers=6.3, archname=MSWin32-x64-multi-thread uname='Win32 strawberry-perl 5.20.2.1 #1 Sat Feb 21 18:04:11 2015 x64' config_args='undef' hint=recommended, useposix=true, d_sigaction=undef useithreads=define, usemultiplicity=define use64bitint=define, use64bitall=undef, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='gcc', ccflags ' -s -O2 -DWIN32 -DWIN64 -DCONSERVATIVE -DPERL_TEXTMODE_SCRIPTS -DPERL_IMPLICIT_CONTEXT -DPERL_IMPLICIT_SYS -DUSE_PERLIO -fwrapv -fno-strict-aliasing -mms-bitfields', optimize='-s -O2', cppflags='-DWIN32' ccversion='', gccversion='4.8.3', gccosandvers='' intsize=4, longsize=4, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12 ivtype='long long', ivsize=8, nvtype='double', nvsize=8, Off_t='long long', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='g++', ldflags ='-s -L"C:\STRAWB~1\perl\lib\CORE" -L"C:\STRAWB~1\c\lib"' libpth=C:\STRAWB~1\c\lib C:\STRAWB~1\c\x86_64-w64-mingw32\lib C:\STRAWB~1\c\lib\gcc\x86_64-w64-mingw32\4.8.3 libs=-lmoldname -lkernel32 -luser32 -lgdi32 -lwinspool -lcomdlg32 -ladvapi32 -lshell32 -lole32 -loleaut32 -lnetapi32 -luuid -lws2_32 -lmpr -lwinmm -lversion -lodbc32 -lodbccp32 -lcomctl32 perllibs=-lmoldname -lkernel32 -luser32 -lgdi32 -lwinspool -lcomdlg32 -ladvapi32 -lshell32 -lole32 -loleaut32 -lnetapi32 -luuid -lws2_32 -lmpr -lwinmm -lversion -lodbc32 -lodbccp32 -lcomctl32 libc=, so=dll, useshrplib=true, libperl=libperl520.a gnulibc_version='' Dynamic Linking: dlsrc=dl_win32.xs, dlext=xs.dll, d_dlsymun=undef, ccdlflags=' ' cccdlflags=' ', lddlflags='-mdll -s -L"C:\STRAWB~1\perl\lib\CORE" -L"C:\STRAWB~1\c\lib"' --- @INC for perl 5.20.2: C:/Strawberry/perl/site/lib C:/Strawberry/perl/vendor/lib C:/Strawberry/perl/lib . --- Environment for perl 5.20.2: HOME (unset) LANG (unset) LANGUAGE (unset) LD_LIBRARY_PATH (unset) LOGDIR (unset) PATH=C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Windows Live\Shared;C:\Tcl\bin;C:\WINDOWS\system32\config\systemprofile\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Strawberry\c\bin;C:\Strawberry\perl\bin;C:\Strawberry\perl\site\bin;C:\Perl64\bin;C:\Perl64\site\bin;C:\WINDOWS\System32\Wbem;C:\Program Files (x86)\PuTTY\;C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit\;C:\Users\Ben (user)\.dnx\bin;C:\rakudo\bin;C:\rakudo\share\perl6\site\bin;%USERPROFILE%\AppData\Local\Microsoft\WindowsApps; PERL_BADLANG (unset) SHELL (unset)
RT-Send-CC: perl5-porters [...] perl.org
Download (untitled) / with headers
text/plain 904b
On Sun, 08 Oct 2017 15:46:21 GMT, ben-goldberg@hotmail.com wrote: Show quoted text
> This is a bug report for perl from ben-goldberg@hotmail.com, > generated with the help of perlbug 1.40 running under perl 5.20.2. > > > ----------------------------------------------------------------- > [Please describe your issue here] > > The documentation of XSLoader and DynaLoader do not make use of > __PACKAGE__, and use outdated indirect method call syntax. > > For example, this line from the doc: > > XSLoader::load('YourPackage', $VERSION); > > Should read: > > XSLoader::load(__PACKAGE__, $VERSION); > > Or alternatively: > > __PACKAGE__->XSLoader::load($VERSION); > > And this line: > > bootstrap YourPackage $VERSION; > > > Should read: > > __PACKAGE__->bootstrap($VERSION); > >
Would you be able to provide a patch drawn against Perl 5 blead? Thank you very much. -- James E Keenan (jkeenan@cpan.org)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

For issues related to this RT instance (aka "perlbug"), please contact perlbug-admin at perl.org