Skip Menu |
Report information
Id: 131366
Status: new
Priority: 0/
Queue: perl6

Owner: Nobody
Requestors: cpan [at] zoffix.com
Cc:
AdminCc:

Severity: (no value)
Tag: Bug
Platform: (no value)
Patch Status: (no value)
VM: (no value)



Subject: [BUG] Mixining in Blob role gives "P6opaque: missing attribute protocol in compose"
Download (untitled) / with headers
text/plain 269b
IRC: https://irclog.perlgeek.de/perl6-dev/2017-05-25#i_14636647 16:02 Zoffix m: class Foo does Blob {} 16:02 camelia rakudo-moar 428324: OUTPUT: «5===SORRY!5=== Error while compiling <tmp>␤P6opaque: missing attribute protocol in compose of Foo␤at <tmp>:1␤»
Download (untitled) / with headers
text/plain 779b
On Thu, 25 May 2017 09:02:59 -0700, cpan@zoffix.com wrote: Show quoted text
> IRC: https://irclog.perlgeek.de/perl6-dev/2017-05-25#i_14636647 > > 16:02 Zoffix m: class Foo does Blob {} > 16:02 camelia rakudo-moar 428324: OUTPUT: «5===SORRY!5=== > Error while compiling <tmp>␤P6opaque: missing attribute protocol in > compose of Foo␤at <tmp>:1␤»
16:03 Zoffix Filed as https://rt.perl.org/Ticket/Display.html?id=131366 16:03 jnthn m: class Foo does Blob is repr('VMArray') {} 16:03 camelia rakudo-moar 428324: ( no output ) 16:03 jnthn Probably needs that 16:04 Zoffix Ahhh 16:04 jnthn: so should I just close the ticket? 16:07 jnthn Zoffix: Hm, we may be able to try and figure out that it needs the different REPR 16:07 I forget exactly how that part works


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

For issues related to this RT instance (aka "perlbug"), please contact perlbug-admin at perl.org