Skip Menu |
Report information
Id: 127483
Status: open
Priority: 0/
Queue: perl6

Owner: Nobody
Requestors: davidnmfarrell [at] gmail.com
Cc:
AdminCc:

Severity: (no value)
Tag: Bug
Platform: (no value)
Patch Status: (no value)
VM: (no value)



Subject: use lib 'lib' and perl6 -Ilib behave differently
Date: Sun, 7 Feb 2016 11:55:03 -0500
To: rakudobug [...] perl.org
From: David Farrell <davidnmfarrell [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
But the issue appears to be perl6's different treatment of "use lib 'lib';" versus the command line: perl6 -Ilib ...

In the case of Pod-Perl5 the test suite passes when -Ilib is not included as an argument to perl6.

Steps to reproduce for a single test:

$ git clone https://github.com/dnmfarrell/Pod-Perl5
Cloning into 'Pod-Perl5'...
remote: Counting objects: 731, done.
remote: Total 731 (delta 0), reused 0 (delta 0), pack-reused 731
Receiving objects: 100% (731/731), 129.62 KiB | 0 bytes/s, done.
Resolving deltas: 100% (350/350), done.
Checking connectivity... done.
$ cd Pod-Perl5/
$ perl6 t/Perl5.t
1..5
ok 1 - Import Pod::Perl5
ok 2 - parse string
ok 3 - parse document
ok 4 - parse document
ok 5 - parse document
$ perl6 -Ilib t/Perl5.t
1..5
ok 1 - Import Pod::Perl5
ok 2 - parse string
ok 3 - parse document
ok 4 - parse document
not ok 5 - parse document

# Failed test 'parse document'
# at t/Perl5.t line 11
# Looks like you failed 1 test of 5

Download (untitled) / with headers
text/plain 130b
Can't reproduce the issue. Are you able to try again with the latest Rakudo, please? -- Cheers, ZZ | https://twitter.com/zoffix


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

For issues related to this RT instance (aka "perlbug"), please contact perlbug-admin at perl.org