Skip Menu |
Report information
Id: 127303
Status: new
Priority: 0/
Queue: perl6

Owner: Nobody
Requestors: lloyd.fourn [at] gmail.com
Cc:
AdminCc:

Severity: (no value)
Tag: (no value)
Platform: (no value)
Patch Status: (no value)
VM: (no value)



To: "rakudobug [...] perl.org" <rakudobug [...] perl.org>
From: Lloyd Fournier <lloyd.fourn [...] gmail.com>
Subject: multi required by role doesn't work with .^mixin
Date: Mon, 18 Jan 2016 04:45:13 +0000
Download (untitled) / with headers
text/plain 328b
role multirequire {
    multi method runtime($var) {...}
}

class Foo  {
    multi method runtime($var) { }
}

Foo.^mixin(multirequire);

Multi method 'runtime' with signature :(Foo+{multirequire} $: $var, *%_) must be implemented by Foo+{multirequire} because it is required by a role

change that to a does and it works fine.
Download (untitled) / with headers
text/plain 142b
Still present in Rakudo version 2016.07.1-88-g15ee3c3 built on MoarVM version 2016.07-11-g11e02fe -- Cheers, ZZ | https://twitter.com/zoffix


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

For issues related to this RT instance (aka "perlbug"), please contact perlbug-admin at perl.org