Skip Menu |
Report information
Id: 127225
Status: new
Priority: 0/
Queue: perl6

Owner: Nobody
Requestors: autarch <autarch [at] urth.org>
Cc:
AdminCc:

Severity: (no value)
Tag: (no value)
Platform: (no value)
Patch Status: (no value)
VM: (no value)



Subject: LTA error message from typed enum declaration
Download (untitled) / with headers
text/plain 223b
perl6 -e 'my Str enum Foo < x y z >' ===SORRY!=== Incompatible MROs in P6opaque rebless I sort of understand that what I wrote isn't actually correct and isn't expected to work, but the error message is very uninformative.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

For issues related to this RT instance (aka "perlbug"), please contact perlbug-admin at perl.org