Skip Menu |
Report information
Id: 126744
Status: new
Priority: 0/
Queue: perl6

Owner: Nobody
Requestors: scolinet [at] gmail.com
Cc:
AdminCc:

Severity: (no value)
Tag: (no value)
Platform: (no value)
Patch Status: (no value)
VM: (no value)



Subject: [SPEC?] Add something in META6 (spec 22) to specify non native dependancy
Download (untitled) / with headers
text/plain 507b
As the title say. It could probably useful to have a syntax/keyword to specify when the module depends on something that is not another perl6 module. Including the version/other There is multiple use for that: Installer can warn the user/admin that they will need something else in order for the module to work. Tools like dh-make-perl (a debian tools that build .dpkg from cpan/source) could add this as dependency if needed. Could be like: extern-depends { "C:libfoo:ver<3.*>", "Python:bar:ver<2.1.2>" }


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

For issues related to this RT instance (aka "perlbug"), please contact perlbug-admin at perl.org