Skip Menu |
Report information
Id: 10008
Status: resolved
Priority: 0/
Queue: perl5

Owner: Nobody
Requestors: gerrit [at] familiehaase.de
Cc:
AdminCc:

Operating System: (no value)
PatchStatus: (no value)
Severity: (no value)
Type: notok
Perl Version: 5.8.0
Fixed In: (no value)



From: Gerrit P. Haase <gerrit [...] familiehaase.de>
Date: Sat, 29 Jun 2002 21:04:32 +0200
To: perlbug [...] perl.org
Subject: Not OK: perl v5.8.0 on cygwin-multi-64int 1.3.12s(0.5332) (UNINSTALLED)
Download (untitled) / with headers
text/plain 3.2k
This is a build failure report for perl from gp@familiehaase.de, generated with the help of perlbug 1.34 running under perl v5.8.0. ----------------------------------------------------------------- [Please enter your report here] Failed 1/709 test scripts, 99.86% okay. 2/65048 subtests failed, 100.00% okay. Failed Test Stat Wstat Total Fail Failed List of Failed ----------------------------------------------------------------------------------------- op/alarm.t 4 2 50.00% 1-2 49 tests and 307 subtests skipped. Since INSTALL states that this may happen I don't mind much;) [Please do not change anything below this line] ----------------------------------------------------------------- --- Flags: category=install severity=none --- Site configuration information for perl v5.8.0: Configured by Gerrit at Sat Jun 29 19:23:24 2002. Summary of my perl5 (revision 5.0 version 8 subversion 0 patch 17381) configuration: Platform: osname=cygwin, osvers=1.3.12s(0.5332), archname=cygwin-multi-64int uname='cygwin_nt-4.0 loreley 1.3.12s(0.5332) 20020627 12:05:02 i686 unknown ' config_args='-de -Dmksymlinks -Dusemultiplicity -Duse64bitint -Doptimize=-g -O2' hint=recommended, useposix=true, d_sigaction=define usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=define useperlio=define d_sfio=undef uselargefiles=define usesocks=undef use64bitint=define use64bitall=undef uselongdouble=undef usemymalloc=y, bincompat5005=undef Compiler: cc='gcc', ccflags ='-DPERL_USE_SAFE_PUTENV -DDEBUGGING -fno-strict-aliasing -I/usr/local/include', optimize='-g -O2', cppflags='-DPERL_USE_SAFE_PUTENV -DDEBUGGING -fno-strict-aliasing -I/usr/local/include' ccversion='', gccversion='2.95.3-5 (cygwin special)', gccosandvers='' intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12 ivtype='long long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=4 alignbytes=8, prototype=define Linker and Libraries: ld='ld2', ldflags =' -g -L/usr/local/lib' libpth=/usr/local/lib /usr/lib /lib libs=-lgdbm -ldb -lcrypt -lutil perllibs=-lcrypt -lutil libc=/usr/lib/libc.a, so=dll, useshrplib=true, libperl=libperl.a gnulibc_version='' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' -g' cccdlflags=' ', lddlflags=' -g -L/usr/local/lib' Locally applied patches: --- @INC for perl v5.8.0: lib /usr/lib/perl5/5.8.0/cygwin-multi-64int /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/cygwin-multi-64int /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl . --- Environment for perl v5.8.0: CYGWIN=ntsec binmode tty nowinsymlinks CYGWIN_ROOT=/ HOME=/home/Gerrit LANG (unset) LANGUAGE (unset) LC_ALL=C LC_CTYPE=C LC_MESSAGES=C LD_LIBRARY_PATH=/usr/lib:/usr/local/lib:/usr/X11R6/lib LOGDIR=/home/logs PATH=/sourcecode/perl/perl58/buildperl:.:.:/bin:/usr/local/bin:/usr/X11R6/bin:/sbin:/usr/sbin:/usr/local/sbin:/usr/local/wrappers:/stuff/devel/sather-1.3-beta-7/bin:/usr/bin:/usr/local:/etc:/usr/lib:/lib:/usr/libexec PERLIO=perlio PERL_BADLANG (unset) SHELL=/bin/sh
Subject: Not OK: perl v5.8.0 on cygwin-multi-64int 1.3.12s(0.5332) (UNINSTALLED)
Hi, could you retry this with either newer cygwin or bleadperl?
Date: Mon, 13 Jan 2003 18:14:36 +0100
From: "Gerrit P. Haase" <gerrit [...] familiehaase.de>
To: Jarkko Hietaniemi <perlbug-followup [...] perl.org>
Subject: Re: [perl #10008] Not OK: perl v5.8.0 on cygwin-multi-64int 1.3.12s(0.5332) (UNINSTALLED)
RT-Send-Cc:
Download (untitled) / with headers
text/plain 202b
Jarkko schrieb: Show quoted text
> Hi, could you retry this with either newer cygwin or bleadperl?
Hmmm, the latest cygwin (1.3.18-1) is somewhat broken, but you may close this bug anyway. Ciao, Gerrit -- =^..^=
Subject: Not OK: perl v5.8.0 on cygwin-multi-64int 1.3.12s(0.5332) (UNINSTALLED)
Download (untitled) / with headers
text/plain 288b
The 20030113 snapshot does not show this behaviour, even after repeated tries to make it go bust. FWIW I guess it is absolutely a Cygwin issue, not due to the tests in perl. I still don't grasp why Hugo would not accept my change to the test, but hey, as all succeeds, who cares :)
Date: Mon, 13 Jan 2003 18:28:32 +0100
From: "H.Merijn Brand" <h.m.brand [...] hccnet.nl>
To: "Gerrit P. Haase" <gerrit [...] familiehaase.de>
Subject: Re: [perl #10008] Not OK: perl v5.8.0 on cygwin-multi-64int 1.3.12s(0.5332) (UNINSTALLED)
Cc: Perl 5 Porters <perl5-porters [...] perl.org>
RT-Send-Cc:
Download (untitled) / with headers
text/plain 716b
On Mon 13 Jan 2003 18:14, "Gerrit P. Haase" <gerrit@familiehaase.de> wrote: Show quoted text
> Jarkko schrieb: >
> > Hi, could you retry this with either newer cygwin or bleadperl?
> > Hmmm, the latest cygwin (1.3.18-1) is somewhat broken, but you may close > this bug anyway.
Closed. Gerrit, can you try the 20030113 snapshot, and see if it's gone with you too? -- H.Merijn Brand Amsterdam Perl Mongers (http://amsterdam.pm.org/) using perl-5.6.1, 5.8.0 & 633 on HP-UX 10.20 & 11.00, AIX 4.2, AIX 4.3, WinNT 4, Win2K pro & WinCE 2.11. Smoking perl CORE: smokers@perl.org http://archives.develooper.com/daily-build@perl.org/ perl-qa@perl.org send smoke reports to: smokers-reports@perl.org, QA: http://qa.perl.org
Date: Tue, 14 Jan 2003 19:41:01 +0100
From: "Gerrit P. Haase" <gerrit [...] familiehaase.de>
To: "H . Merijn Brand" <perlbug-followup [...] perl.org>
Subject: Re: [perl #10008] Not OK: perl v5.8.0 on cygwin-multi-64int 1.3.12s(0.5332) (UNINSTALLED)
RT-Send-Cc:
Download (untitled) / with headers
text/plain 710b
H schrieb: Show quoted text
> On Mon 13 Jan 2003 18:14, "Gerrit P. Haase" <gerrit@familiehaase.de> wrote:
>> Jarkko schrieb: >>
>> > Hi, could you retry this with either newer cygwin or bleadperl?
>> >> Hmmm, the latest cygwin (1.3.18-1) is somewhat broken, but you may close >> this bug anyway.
Show quoted text
> Closed. Gerrit, can you try the 20030113 snapshot, and see if it's gone with > you too?
Ok, with the snapshot from 2003-01-13 and perl-5.8 all seems to work well: All tests successful. u=7.843 s=7.078 cu=385.673 cs=157.102 scripts=664 tests=68577 make[2]: Leaving directory `/usr/src/buildperl' make[1]: Leaving directory `/usr/src/buildperl' Will test bleadperl tomorrow, got to go home now ... Gerrit -- =^..^=


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

For issues related to this RT instance (aka "perlbug"), please contact perlbug-admin at perl.org